Monday 11 March 2013

Routing Protocol

Metrics: - 

It is a technique which is used to measure best path for routing. For selection of best path it uses different measurement units:-

o HOP count: - Number of routes in the path to reach to the destination.

o Bandwidth: - it need total data transmission of a link in a second kbps, mbps, gbps.

o Delay: - Total time taken into transmission of data is known as delay.

o Reliability: - It measure successful transmission of data units between source and destination.

o Load: - Total data transmission load at the link.

o Cost: - It is a ratio of total bandwidth by the actual bandwidth .i.e. used for transmission. It is calculated between two nodes.

Administrative Distance (A.D.) – 

It is used to priorities to a path send by a routing protocol. It is a numeric value that range is 0-255. Each routing protocol has pre-assigned administrative distance.

OSPF - 110

RIP - 120

Routing protocols types on the basis of metrics:- 


o Distance Vector: - 

It works at hop count to measure the best path between 2 nodes. It sends update at a fix interval of time. Its sends full routing table to its neighbor router. It may cause of routing loop .i.e. removed using split horizon, route poisoning and increment of hop count.

RIP (Routing Information Protocol)
· AD value – 120

· Distance Vector Routing Protocol

· Keeps information about neighbor router only

· Sends update at every 30 minutes with full routing table information.

· Supports maximum 15 hop counts.

· Works at Belmone Ford algorithm to find out best path.

· Supports broadcasting

· Does not support authentication

· Its root invalid timer is 180 seconds

· Its root hold down timer is 180 seconds

· Its root flush timer is 240 seconds

· Supports class full addressing

RIP version 2 :- 
Its most of features are similar to RIP except the following:-

· Supports authentication

· Supports class less addressing

· Supports authentication with MD5(Message Digest 5) 
------------------------------------------------------------------------------------------------------------

For example:- R1 RIP configuration.
Router>en

Router#conf t

Router(config)#hostname R1

R1(config)#int fa0/0

R1(config-if)#ip add 10.0.0.1 255.0.0.0

R1(config-if)#no shut

R1(config-if)#int s0/0/0

R1(config-if)#ip add 11.0.0.1 255.0.0.0

R1(config-if)#clock rate 64000

R1(config-if)#no shut

R1(config-if)#exit

R1(config)#router rip

R1(config)#net 10.0.0.0

R1(config)#net 11.0.0.0

R1(config)#exit

R2 RIP Configuration
Router>en

Router#conf t

Router(config)#hostname R2

R2(config)#int fa0/0

R2(config-if)#ip add 172.16.0.1 255.255.0.0

R2(config-if)#no shut

R2(config-if)#int s0/0/0

R2(config-if)#ip add 11.0.0.2 255.0.0.0

R2(config-if)#no shut

R2(config-if)#int s0/1/0

R2(config-if)#ip add 12.0.0.1 255.0.0.0

R2(config-if)#clock rate 64000

R2(config-if)#no shut

R2(config-if)#exit

R2(config)#router rip

R2(config)#net 11.0.0.0

R2(config)#net 12.0.0.0

R2(config)#net 172.16.0.0

R2(config)#exit

R3 RIP Configuration
Router>en

Router#conf t

Router(config)#hostname R3

R3(config)#int fa0/0

R3(config-if)#ip add 192.168.0.1 255.255.255.0

R3(config-if)#no shut

R3(config-if)#int s0/0/0

R3(config-if)#ip add 12.0.0.2 255.0.0.0

R3(config-if)#clock rate 64000

R3(config-if)#no shut

R3(config-if)#exit

R3(config)#router rip

R3(config)#net 12.0.0.0

R3(config)#net 192.168.0.0


R3(config)#exit 

-----------------------------------------------------------------
For example:- R1 RIPv2 Configuration
Router>en

Router#conf t

Router(config)#hostname R1

R1(config)#int fa0/0

R1(config-if)#ip add 10.0.0.1 255.255.255.192

R1(config-if)#no shut

R1(config-if)#int s0/0/0

R1(config-if)#ip add 10.0.0.113 255.255.255.252

R1(config-if)#clock rate 64000

R1(config-if)#no shut

R1(config-if)#exit

R1(config)#router rip

R1(config)#version 2

R1(config)#net 10.0.0.0

R1(config)#net 10.0.0.112

R1(config)#exit
R2 RIPv2 Configuration
Router>en

Router#conf t

Router(config)#hostname R2

R2(config)#int fa0/0

R2(config-if)#ip add 10.0.0.65 255.255.255.224

R2(config-if)#no shut

R2(config-if)#int s0/0/0

R2(config-if)#ip add 10.0.0.114 255.255.255.252

R2(config-if)#no shut

R2(config-if)#int s0/1/0

R2(config-if)#ip add 10.0.0.117 255.255.255.252

R2(config-if)#clock rate 64000

R2(config-if)#no shut

R2(config-if)#exit

R2(config)#router rip

R2(config)#version 2

R2(config)#net 10.0.0.112

R2(config)#net 10.0.0.64

R2(config)#net 10.0.0.116

R2(config)#exit

R3 RIPv2 Configuration

Router>en

Router#conf t

Router(config)#hostname R3

R3(config)#int fa0/0

R3(config-if)#ip add 10.0.0.97 255.255.255.240

R3(config-if)#no shut

R3(config-if)#int s0/0/0

R3(config-if)#ip add 10.0.0.118 255.255.255.252

R3(config-if)#clock rate 64000

R3(config-if)#no shut

R3(config-if)#exit

R3(config)#router rip

R3(config)#version 2

R3(config)#net 10.0.0.116

R3(config)#net 10.0.0.96


R3(config)#exit

Sunday 10 March 2013

Routing

Routing

It is a method for communication between two or more different network using a routing table.

In routing, Routers select best path before transmission of data.

This best path is collected into a table .i.e. known as routing table.

Types of Routing

a) Static Routing

In this routing, routers are defined manually.

It is mostly done at terminal router in a large network and complete configuration is done in a small network.

In each path, we have to specify:-

#ip route <Network IP> <Subnet Mask> <Next Hop Router Address>

for example:

#ip route 192.168.0.0 255.255.255.0 11.0.0.2
------------------------------------------------------------------------------------------------------------

If we want to established communication between 2 Routers with 2 different networks then we need to connect both routers with Serial port and cable.

After that we should to configure both routers with some following commands:-

First we have to configure Router1:-

Router1>en

Router1#conf t

Router1(config)#int fa0/0

Router1(config-if)#ip add 10.0.0.1 255.0.0.0

Router1(config-if)#no shut

Router1(config-if)#int s0/0/0

Router1(config-if)#ip add 11.0.0.1 255.0.0.0

Router1(config-if)#clock rate 64000

Router1(config-if)#no shut

Router1(config-if)#ip route 192.168.0.0 255.255.255.0 11.0.0.2

Router1(config-if)#^z







After that we need to configure Router2:-

Router2>en

Router2#conf t

Router2(config)#int fa0/0

Router2(config-if)#ip add 192.168.0.1 255.255.255.0

Router2(config-if)#no shut

Router2(config-if)#int s0/0/0

Router2(config-if)#ip add 11.0.0.2 255.0.0.0

Router2(config-if)#no shut

Router2(config-if)#ip route 10.0.0.0 255.0.0.0 11.0.0.1

Router2(config-if)#^z

------------------------------------------------------------------------------------------------------------

Static Default Routing


A default route with all 0s for network IP & subnet mask is used.

It can only be done at terminal router means which has only 1 exit point to communicate with another networks.

for example:-


Router1>en

Router1#conf t

Router1(config)#int fa0/0

Router1(config-if)#ip add 10.0.0.1 255.0.0.0

Router1(config-if)#no shut

Router1(config-if)#int s0/0/0

Router1(config-if)#ip add 11.0.0.1 255.0.0.0

Router1(config-if)#clock rate 64000

Router1(config-if)#no shut

Router1(config-if)#ip route 0.0.0.0 0.0.0.0 11.0.0.2

Router1(config-if)#^z



and on Router2



Router2>en

Router2#conf t

Router2(config)#int fa0/0

Router2(config-if)#ip add 192.168.0.1 255.255.255.0

Router2(config-if)#no shut

Router2(config-if)#int s0/0/0

Router2(config-if)#ip add 11.0.0.2 255.0.0.0

Router2(config-if)#no shut

Router2(config-if)#ip route 0.0.0.0 0.0.0.0 11.0.0.1

Router2(config-if)#^z
-----------------------------------------------------------------

Dynamic Routing

A routing which is done with the help of routing protocols is known as dynamic routing. Here these routing protocols are responsible for creation, deletion and updating routing table. It is east tot configure and manage. 

Types of Dynamic Routing Protocol

IGP (Interior Gateway Protocol):- It provides communication into single autonomous system. 
Example- RIP, EIGRP, OSPF

EGP (Exterior Gateway Protocol):- It provides communication between different autonomous systems.                                      
Example- BGP.

Wednesday 6 March 2013

Router Flash Memory

Hello Friends,

In this post, we learn details of Flash memory of Router and how flash memory serial number helps to recognize  the features of Router and Memory.

Lets starts with Flash Memory:

Flash Memory is EEPROM.

Flash Memory stores IOS.

If system image file is: "flash:C3620-ik9o3s7-mz.123-25.bin"

Table 1.

Image Letter        Feature Set

I                   IP
Y                   IP on 1700 series platform
S                   IP Plus
S6                  IP Plus - No ATM
S7                  IP Plus - No Voice
J                   Enterprise
O                   IOS Firewall/Intrusion Detection.
K                   Cryptography/IPSEC/SSH
K8                  56 bit DES Encryption/Weak Cryptography
K9                  3DES/AES Encryption/Strong Cryptography
X                   H323
G                   Services Selection Gateway
C                   Remote Access Server/Packet Data Serving Node
B                   Apple Talk
N                   Novel IP/IPX
V                   VOX
R                   IBM
U                   Unlawful Intercept
P                   Service Provider
Telco               Telecommunication Feature Set
Boot                Boot Image(Used on high end Routers/Switches)


Table 2

Image Letter       IOS boot location
F                  The image executes from flash memory
M                  The image executes from RAM
R                  The image executes from ROM
L                  The image is relocatable
Z                  The image is compressed using ZIP format
X                  The image is compressed using MZIP format
W                  The image is compressed using STAC format


When we break down the naming convention of the image name:-

C3620   = Hardware
ik9o3s7 = Feature Set (Table 1)
mz      = IOS boot location(Table 2)
123     = Maintainance Release
25      = Individual Release
.bin    = File Extension Name
               

LAN Configuration

Steps


1


First and foremost, attach the RJ-45 connector to the Ethernet network port on your PC.


2.


Right click on ‘My Network Places’ icons located on the desktop and in the popup menu click on properties. Alternatively, click ‘Start’ from the taskbar and right click on ‘My Network Places’ option from the popup menu. In the menu that appears select ‘Properties’


3


In the new Window that appears, under the LAN or High-Speed internet, right on ‘Local Area Connection’ and select properties in the popup menu that appears.


4


In the local area connection dialog box that appears under the connection box, scroll down and select ‘Internet Protocol (TCP/IP) and click on ‘Properties.


5


To configure your PC, you can opt for obtaining the configuration settings automatically or manually. To obtain the settings automatically, select ‘Obtain an IP Address Automatically’. However, to use this option, you will need to have a DHCP server that will function in allocating and managing IP address to ensure that there are no conflicts. To configure your PC to the network manually, follow the procedures listed below:

Click the option ‘Use the following IP Address’. Enter the IP address to use. It is important that you consult your network administrator on the IP to use so as to avoid conflicts occurring in the network, i.e. a situation where two PCs have similar IP addresses. Thereafter, enter the Subnet Mask and Default gateway. #*The subnet mask is used to identify the network level you are in while the default gateway identifies the router connection.

Thereafter, enter the Preferred DNS server and Alternate DNS server address.

Click ‘OK’ to accept the changes or ‘cancel’ to exit the setup.

6

Check the option ‘Show icon in notification area when connected’ and #click ‘OK”. This will enable you to know if the local area connection is connected or disconnected.

Tuesday 5 March 2013

Full Forms in field of Networking

CCNA     - Cisco Certified Network Associate
CCNP     - Cisco Certified Network Professional
LAN      - Local Area Network
WAN      - Wide Area Network
SAN      - Storage Area Network
IEEE     - Institute of Electrical and Electronic Engineering
MAU      - Multiple Access Unit
VLAN     - Virtual Local Area Network
I/O BOX  - Information Output Box
FCC      - Federal Communication Commision
ISP      - Internet Service Provider
TPC      - Twisted Pair Cable
CSMA/CD  - Carrier Sense Multiple Access/ Collision Domain
ASIC     - Application Specific Integrated Circuit
CAM      - Content Addressable Memory
MAC      - Media Access Control
OS       - Operating System
IP       - Internet Protocol
RAM      - Random Access Memory
ROM      - Read Only Memory
NVRAM    - Non Volatile Random Access Memory
IOS      - Internetwork Operating System
BRI      - Basic Rate Interface
PRI      - Primary Rate Interface
ISDN     - Integrated Service Digital Network
TIA      - Telecommunication Industries Association
EIA      - Electronic Industries Alliances
UTP      - Unsheilded Twisted Pair
STP      - Sheilded Twisted Pair
FOC      - Fiber Optic Cable
EMI      - Electro Magnetic Interference
OSI      - Open System Interconnection
LLC      - Logical Link Control
SSL      - Secure Socket Layer
DHCP     - Dynamic Host Configuration Protocol
TELNET   - Telecommunication Network
FTP      - File Transfer Protocol
TCP      - Transmission Control Protocol
ADDS     - Active Directory Domain Service
NETBIOS  - Network Basic Input Output System
DNS      - Domain Name System
DORA     - Discover, Offer, Request,                Acknowledgement
APIPA    - Automatic Private Internet Protocol Address
BOOTP    - Boot Protocol
WINS     - Windows Internet Network Service
HTTP     - Hyper Text Transfer Protocol
HTTPS    - Hyper Text Transfer Protocol Secure
NNTP     - Network News Transfer Protocol
SMTP     - Simple Mail Transfer Protocol
POP      - Post Office Protocol
IMAP     - Internet Messege Access Protocol
UDP      - User Datagram Protocol
ICMP     - Internet Control Messege Protocol
ARP      - Address Resolution Protocol
RARP     - Reverse Address Resolution Protocol
CIDR     - Classless Inter Domain Routing
VLSM     - Variable Length Subnet Mask
POST     - Power On Startup Text
CLI      - Command Line Interface
GUI      - Graphical User Interface
BGP      - Border Gateway Protocol
IANA     - Internet Assigned Numbers Authority
NIC      - Network Interface Card
OUI      - Organizational Unique Identifier
WAP      - Wireless Access Protocol
WEP      - Wired Equivalent Privacy
TKIP     - Temporal Key Integrity Protocol
STP      - Spanning Tree Protocol
RSTP     - Rapid Spanning Tree Protocol
BPDU     - Bridge Protocol Data Unit
RTF      - Rapid Transitioning to Forwarding
LACP     - Link Aggregation Control Protocol
PAgP     - Port Aggregation Protocol
DTP      - Dynamic Trunking Protocol
CoS      - Class of Service
CRC      - Cyclic Redundancy Check
DIFS     - Distributed Inter frame Space
WLAN     - Wireless Local Area Network
DRS      - Dynamic Rate Shifting
SSID     - Service Set Identifier
WPA      - Wi-Fi Protected Access
VPN      - Virtual Private Network
SSH      - Secure Shell
TLS      - Transport Layer Security
RADIUS   - Remote Authentication Dial In User Service
IDS      - Intrusion Detection System
IPS      - Intrusion Prevention System
Ad Hoc   - Computer to Computer Network
LWAPP    - Light Weight Access Point Protocol
BSS      - Basic Sevice Set
ESS      - Extended Service Set
CUWN     - Cisco Unified Wireless Network
AWPP     - Adaptive Wireless Path Protocol
QoS      - Quality of Service
OTAP     - Over The Air Provisioning
ISR      - Integrated Service Router
ACL      - Access Control List
NAT      - Network Address Translation
DMZ      - Demiliatarized Zone
DoS      - Denial of Service
ISN      - Initial Sequence Number
SQN      - Sequence Number
RSH      - Remote Shell
RCP      - Remote Copy Protocol
PAT      - Port Address Translation
IP Sec   - Internet Protocol Security
DES      - Data Encryption Standard
DCE      - Data Communication Equipment
DTE      - Data Terminal Equipment
EEPROM   - Electrically Erasable Programmable Read Only Memory.
RIP      - Routing Information Protocol
AD Value - Administrative Distance
MD5      - Message Digest 5

TCP/IP Ports

TCP/IP ports are defined by the IANA.


  • 0 - 1023 ---- Well known TCP/IP ports. These ports are reserved for standard TCP/IP network applications and protocols.

  • 1024 - 49151 ---- Registered TCP/IP ports. These ports are reserved for applications that are registered by various corporations. However, many companies today are using the private TCP/IP ports range instead.

  • 49152 - 65535 ---- Private TCP/IP ports. These ports are available for anyone to use. Companies that write network applications typically allow the users to configure the TCP/IP ports manually in this port number range. This is a flexible and reliable solution for most network applications.


Telnet - 23
FTP    - 20, 21
HTTP   - 80,8080
NNTP   - 119
HTTPS  - 443
SMTP   - 25
DNS    - 53
POP    - 110
SSH    - 22
DHCP   - 67,68
SNMP   - 161
BOOTP  - 67, 68
RIP    - 520, 521
NTP    - 123
IRC    - 194
SMB    - 445
Syslog - 514

Recovering IOS on a 2600 Series


Step 1. Assuming that you already have an active console session to the router and the device is powered you should automatically be placed into ROMMON if you’re Cisco IOS image is corrupt or missing. However you have “Press Return to get started” Prompt then you’ve booted into an IOS image, you should power cycle the router and press CTRL+BREAK repeatedly to break the boot sequence and be placed into ROM Monitor mode as shown below;
System Bootstrap, Version 12.2(8r) [cmong 8r], RELEASE SOFTWARE (fc1)
Copyright (c) 2003 by cisco Systems, Inc.
C2600 platform with 262144 Kbytes of main memory

device does not contain a valid magic number
boot: cannot open "flash:"
boot: cannot determine first file name on device "flash:"

rommon 1 >
By executing the help command you can see all the available commands in ROMMON as shown below on the 2651XM;
rommon 1 > help    
alias               set and display aliases command
boot                boot up an external process
break               set/show/clear the breakpoint
confreg             configuration register utility
cont                continue executing a downloaded image
context             display the context of a loaded image
cookie              display contents of cookie PROM in hex
dev                 list the device table
dir                 list files in file system
dis                 display instruction stream
dnld                serial download a program module
frame               print out a selected stack frame
help                monitor builtin command help
history             monitor command history
meminfo             main memory information
repeat              repeat a monitor command
reset               system reset
set                 display the monitor variables
stack               produce a stack trace
sync                write monitor environment to NVRAM
sysret              print out info from last system return
tftpdnld            tftp image download
unalias             unset an alias
unset               unset a monitor variable
xmodem              x/ymodem image download
rommon 2 >
Step 2. In this lab we are most interested in the tftpdnld command.
This command will copy an IOS image from a TFTP Server into flash or load it directly into RAM. By executing the tftpdnld you can view all required variables for the command to operate properly;
rommon 2 > tftpdnld

Missing or illegal ip address for variable IP_ADDRESS
Illegal IP address.

usage: tftpdnld [-r]
  Use this command for disaster recovery only to recover an image via TFTP.
  Monitor variables are used to set up parameters for the transfer.
  (Syntax: "VARIABLE_NAME=value" and use "set" to show current variables.)
  "ctrl-c" or "break" stops the transfer before flash erase begins.

  The following variables are REQUIRED to be set for tftpdnld:
            IP_ADDRESS: The IP address for this unit
        IP_SUBNET_MASK: The subnet mask for this unit
       DEFAULT_GATEWAY: The default gateway for this unit
           TFTP_SERVER: The IP address of the server to fetch from
             TFTP_FILE: The filename to fetch

  The following variables are OPTIONAL:
          TFTP_VERBOSE: Print setting. 0=quiet, 1=progress(default), 2=verbose
      TFTP_RETRY_COUNT: Retry count for ARP and TFTP (default=12)
          TFTP_TIMEOUT: Overall timeout of operation in seconds (default=7200)
         TFTP_CHECKSUM: Perform checksum test on image, 0=no, 1=yes (default=1)
         FE_SPEED_MODE: 0=10/hdx, 1=10/fdx, 2=100/hdx, 3=100/fdx, 4=Auto(deflt)

  Command line options:
   -r: do not write flash, load to DRAM only and launch image
rommon 3 >
As per the objectives, we’re required to set the required variables to execute the tftpdnld command. You can issue the set command to view the current set variables.
rommon 3 > set
PS1=rommon ! > 
BOOT=
RET_2_RUTC=0
BSI=0
RANDOM_NUM=1492875412
ROM_PERSISTENT_UTC=1016225763
RET_2_RTS=
RET_2_RCALTS=
?=1
rommon 24 > set
PS1=rommon ! > 
BOOT=
RET_2_RUTC=0
BSI=0
RANDOM_NUM=1492875412
ROM_PERSISTENT_UTC=1016225763
RET_2_RTS=
RET_2_RCALTS=
?=0
rommon 4 >
Shown below is the required variables to execute tftpdnld successfully.
rommon 4 > IP_ADDRESS=10.1.1.10
rommon 5 > IP_SUBNET_MASK=255.255.255.0
rommon 6 > DEFAULT_GATEWAY=10.1.1.254
rommon 7 > TFTP_SERVER=172.16.20.17
rommon 8 > TFTP_FILE=c2600-i-mz.123-26.bin
You do not need a default gateway if your TFTP Server is on the same subnet as the Cisco router you’re recovering.
Once you have set the variables you can continue on to objective 3 by executing the tftpdnld command with the -r switch to copy the Cisco IOS image from a TFTP Server and load it into ram directly.
rommon 9 > tftpdnld -r

          IP_ADDRESS: 10.1.1.10
      IP_SUBNET_MASK: 255.255.255.0
     DEFAULT_GATEWAY: 10.1.1.254
         TFTP_SERVER: 172.16.20.17
           TFTP_FILE: c2600-i-mz.123-26.bin
.....
Receiving c2600-i-mz.123-26.bin from 172.16.20.17 !!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
File reception completed.
program load complete, entry point: 0x80008000, size: 0x765238
Self decompressing the image : ##############################################
####################################################################### [OK]

Smart Init is enabled
smart init is sizing iomem
  ID            MEMORY_REQ                 TYPE
00036F          0X00103980 C2651XM Dual Fast Ethernet
000065          0X00031500 Four port Voice PM
                0X00098670 public buffer pools
                0X00211000 public particle pools
TOTAL:          0X003DE4F0

If any of the above Memory Requirements are 
"UNKNOWN", you may be using an unsupported
configuration or there is a software problem and
system operation may be compromised.
Rounded IOMEM up to: 4Mb.
Using 3 percent iomem. [4Mb/128Mb]

              Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

           cisco Systems, Inc.
           170 West Tasman Drive
           San Jose, California 95134-1706



Cisco Internetwork Operating System Software 
IOS (tm) C2600 Software (C2600-I-M), Version 12.3(26), RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by cisco Systems, Inc.
Compiled Mon 17-Mar-08 15:23 by dchih

cisco 2651XM (MPC860P) processor (revision 0x200) with 126976K/4096K bytes of memory.
Processor board ID JAE08030QZL (457188033)
M860 processor: part number 5, mask 2
Bridging software.
X.25 software, Version 3.0.0.
2 FastEthernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
32K bytes of non-volatile configuration memory.
49152K bytes of processor board System flash (Read/Write)


         --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]: 
After you’ve booted your Cisco Router into IOS you may be prompted by the Initial configuration Dialog, type no and press return.
Once you’re at the IOS command line you’ll then need to copy an actual image into flash. You’re probably thinking why did we not just copy it using TFTPDNLD and the answer is quite simple. Using TFTPDNLD will take significantly longer to copy an image via TFTP to flash verses booting into RAM and doing a quick IOS image recovery as you’ve done in a previous lab.
The next step is to copy the IOS image from the TFTP Server in Cisco IOS. As shown below the typical prerequisite configuration required to copy an IOS image from a tftp server to flash.
Router>enable
Router#configure terminal
Router(config)#interface fa0/0
Router(config-if)#ip add 10.1.1.10 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#ip route 0.0.0.0 0.0.0.0 10.1.1.254
Router(config)#end
Router#
After you’ve configured the required configuration to copy an IOS image via TFTP to the Router’s flash you can execute the copy command as shown below;
Router#copy tftp flash
Address or name of remote host []? 172.16.20.17
Source filename []? c2600-adventerprisek9-mz.124-1.bin
Destination filename [c2600-adventerprisek9-mz.124-1.bin]? 
Accessing tftp://172.16.20.17/c2600-adventerprisek9-mz.124-1.bin...
Erase flash: before copying? [confirm]
Erasing the flash filesystem will remove all files! Continue? [confirm]
Erasing device... eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee
eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee
eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee ...erased
Erase of flash: complete
Loading c2600-adventerprisek9-mz.124-1.bin from 172.16.20.17 (via FastEthernet0/0):
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
[OK - 34634180 bytes]

Verifying checksum...  OK (0x8E89)
34634180 bytes copied in 279.014 secs (124131 bytes/sec)
Router#
Now that the new IOS image has copied to flash reload your router and verify that the router reboots.
Router#reload

System configuration has been modified. Save? [yes/no]: no
Proceed with reload? [confirm]

SYS-5-RELOAD: Reload requested by console. Reload Reason: Reload command.

System Bootstrap, Version 12.2(8r) [cmong 8r], RELEASE SOFTWARE (fc1)
Copyright (c) 2003 by cisco Systems, Inc.
C2600 platform with 262144 Kbytes of main memory

program load complete, entry point: 0x80008000, size: 0x2107824
Self decompressing the image : ######################################


Smart Init is enabled
smart init is sizing iomem
  ID            MEMORY_REQ                 TYPE
00036F          0X00103980 C2651XM Dual Fast Ethernet
000065          0X00031500 Four port Voice PM
                0X00098670 public buffer pools
                0X00211000 public particle pools
TOTAL:          0X003DE4F0

If any of the above Memory Requirements are 
"UNKNOWN", you may be using an unsupported
configuration or there is a software problem and
system operation may be compromised.
Rounded IOMEM up to: 3Mb.
Using 1 percent iomem. [3Mb/256Mb]

Increasing IOMEM up to: 8Mb
              Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

           cisco Systems, Inc.
           170 West Tasman Drive
           San Jose, California 95134-1706



Cisco IOS Software, C2600 Software (C2600-ADVENTERPRISEK9-M), Version 12.4(1), RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Wed 28-Oct-09 18:16 by prod_rel_team
Image text-base: 0x800080F8, data-base: 0x83594B3C


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 2651XM (MPC860P) processor (revision 2.0) with 253952K/8192K bytes of memory.
Processor board ID JAE08030QZL
M860 processor: part number 5, mask 2
2 FastEthernet interfaces
2 Serial interfaces
32K bytes of NVRAM.
49152K bytes of processor board System flash (Read/Write)


         --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]:

To format Flash Memory

To format an external compact Flash memory card, refer to this sample output:


Router# erase slot0: 

Erasing the slot0 filesystem will remove all files! Continue? [confirm] 
Current DOS File System flash card in slot0: will be formatted into Low End File System flash card! Continue? [confirm] 

Erasing device... eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee ...erased 

Erase of slot0: complete

Back up and Restore Configuration Files (Router)

Use a TFTP Server to Backup and Restore a Configuration


This is a step−by−step approach to copy a configuration from a router to a TFTP server, and back to another router. Before you proceed with this method, make sure you have a TFTP server on the network to which you have IP connectivity.

1. At the Router> prompt, issue the enable command, and provide the required password when prompted.

The prompt changes to Router#, which indicates that the router is now in privileged mode.

2. Copy the running configuration file to the TFTP server:

Router#copy running−config tftp:
Address or name of remote host []? 64.104.207.171

Destination filename [Router−confg]? backup_cfg_for_my_router !!


1030 bytes copied in 2.489 secs (395 bytes/sec)

Router#


3.  Open the configuration file with a text editor. Search for and remove any line that starts with "AAA".

Note: This step is to remove any security commands that can lock you out of the router.

4. Copy the configuration file from the TFTP server to a new router in privileged (enable) mode which has a basic configuration.

Router#copy tftp: running−config
Address or name of remote host []? 64.104.207.171

Source filename []? backup_cfg_for_my_router
Destination filename [running−config]?

Accessing tftp://10.66.64.10/backup_cfg_for_my_router...

Loading backup_cfg_for_router from 64.104.207.171 (via FastEthernet0/0): !

[OK − 1030 bytes]

1030 bytes copied in 9.612 secs (107 bytes/sec)

Router#

Monday 4 March 2013

Password Recovery Procedure for Router

This section describes two procedures to recover your passwords.


Procedure 1

Complete these steps in order to recover your password:

1. Attach a terminal or PC with terminal emulation to the console port of the router.


2. If you can access the router, type show version at the prompt, and record the configuration register setting.

See Example of Password Recovery Procedure in order to view the output of a show version command.

Note: The configuration register is usually set to 0x2102 or 0x102. If you can no longer access the router, you can safely assume that your configuration register is set to 0x2102.

3. Use the power switch in order to turn off the router, and then turn the router back on.

4. Press Break on the terminal keyboard within 60 seconds of power up in order to put the router into ROMmon.

5. Type confreg 0x2142 at the rommon 1> prompt in order to boot from Flash.

This step bypasses the startup configuration where the passwords are stored.

6. Type reset at the rommon 2> prompt.

The router reboots, but ignores the saved configuration.

7. Type no after each setup question, or press Ctrl−C in order to skip the initial setup procedure.

8. Type enable at the Router> prompt.

You are in enable mode and should see the Router# prompt.

Type configure memory or copy startup−config running−config in order to copy the nonvolatile RAM (NVRAM) into memory.

Warning: Do not type copy running−config startup−config or write. These commands erase your startup configuration.

9. Type show running−config.

The show running−config command shows the configuration of the router. In this configuration, the shutdown command appears under all interfaces, which indicates all interfaces are currently shut down. In addition, the passwords (enable password, enable secret, vty, console passwords) are in either an encrypted or unencrypted format. You can reuse unencrypted passwords. You must change encrypted passwords to a new password.

10. Type configure terminal.

The hostname(config)# prompt appears.

11. Type enable secret <password> in order to change the enable secret password.

For example:

hostname(config)#enable secret cisco

12. Issue the no shutdown command on every interface that you use.

If you issue a show ip interface brief command, every interface that you want to use should display up up.

13. Type config−register <configuration_register_setting>. Where configuration_register_setting is either the value you recorded in step 2 or 0x2102 .

For example:

hostname(config)#config−register 0x2102

14. Press Ctrl−z or end in order to leave the configuration mode.

15. The hostname# prompt appears.

16. Type write memory or copy running−config startup−config in order to commit the changes.

------------------------------------------------------------------------------------------------------------

Procedure 2


Complete these steps in order to recover your password:

1. Shut down the router.

2. Remove the compact flash that is at the back of the router.

3. Power on the router.

Once the Rommon1> prompt appears.

4. Enter this command: confreg 0x2142

5. Insert the compact flash.

6. Type reset.

7. When you are prompted to enter the initial configuration, type No, and press Enter.

8. At the Router> prompt, type enable.

At the Router# prompt, enter the configure memory command.

9. Press Enter in order to copy the startup configuration to the running configuration.

10. Use the config t command in order to enter global configuration mode.Use this command in order to create a new user name and password:

router(config)#username cisco privilege 15 password cisco

11. Use this command in order to change the boot statement:

config−register 0x2102

12. Use this command in order to save the configuration:

write memory

13. Reload the router, and then use the new user name and password to log in to the router.

------------------------------------------------------------------------------------------------------------

Example of Password Recovery Procedure


This section provides an example of the password recovery procedure. This example was created with a Cisco 2600 Series Router. Even if you do not use a Cisco 2600 Series Router, this output provides an example of what you should experience on your product.

Router>enable

Password:

Password:

Password:

Bad secrets

Router>show version

Cisco Internetwork Operating System Software IOS (tm) C2600 Software (C2600−IS−M), Version 12.0(7)T, RELEASE SOFTWARE (fc2)

Copyright (c) 1986−1999 by cisco Systems, Inc.

Compiled Tue 07−Dec−99 02:21 by phanguye

Image text−base: 0x80008088, data−base: 0x80C524F8

ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

Router uptime is 3 minutes

System returned to ROM by abort at PC 0x802D0B60

System image file is "flash:c2600−is−mz.120−7.T"

cisco 2611 (MPC860) processor (revision 0x202) with 26624K/6144K bytes of memory.

Processor board ID JAB031202NK (3878188963)

M860 processor: part number 0, mask 49

Bridging software.

X.25 software, Version 3.0.0.

Basic Rate ISDN software, Version 1.1.

2 Ethernet/IEEE 802.3 interface(s)

2 Serial(sync/async) network interface(s)

1 ISDN Basic Rate interface(s)

32K bytes of non−volatile configuration memory.

8192K bytes of processor board System flash partition 1 (Read/Write)

8192K bytes of processor board System flash partition 2 (Read/Write)

Configuration register is 0x2102

Router>

!−−− The router was just powercycled, and during bootup a

!−−− break sequence was sent to the router.

!*** System received an abort due to Break Key ***

signal= 0x3, code= 0x500, context= 0x813ac158

PC = 0x802d0b60, Vector = 0x500, SP = 0x80006030

rommon 1 > confreg 0x2142

You must reset or power cycle for new config to take effect

rommon 2 > reset

System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

Copyright (c) 1999 by cisco Systems, Inc.

TAC:Home:SW:IOS:Specials for info

C2600 platform with 32768 Kbytes of main memory

program load complete, entry point: 0x80008000, size: 0x6fdb4c

Self decompressing the image : ###############################

##############################################################

##############################################################

##############################################################

############################### [OK]

Restricted Rights Legend

Use, duplication, or disclosure by the Government is

subject to restrictions as set forth in subparagraph

(c) of the Commercial Computer Software − Restricted

Rights clause at FAR sec. 52.227−19 and subparagraph

(c) (1) (ii) of the Rights in Technical Data and Computer

Software clause at DFARS sec. 252.227−7013.

cisco Systems, Inc.

170 West Tasman Drive

San Jose, California 95134−1706

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600−IS−M), Version 12.0(7)T, RELEASE SOFTWARE (fc2)

Copyright (c) 1986−1999 by cisco Systems, Inc.

Compiled Tue 07−Dec−99 02:21 by phanguye

Image text−base: 0x80008088, data−base: 0x80C524F8

cisco 2611 (MPC860) processor (revision 0x202) with 26624K/6144K bytes of memory.

Processor board ID JAB031202NK (3878188963)

M860 processor: part number 0, mask 49

Bridging software.

X.25 software, Version 3.0.0.

Basic Rate ISDN software, Version 1.1.

2 Ethernet/IEEE 802.3 interface(s)

2 Serial(sync/async) network interface(s)

1 ISDN Basic Rate interface(s)

32K bytes of non−volatile configuration memory.

8192K bytes of processor board System flash partition 1 (Read/Write)

8192K bytes of processor board System flash partition 2 (Read/Write)

−−− System Configuration Dialog −−−

Would you like to enter the initial configuration dialog? [yes/no]: n

Press RETURN to get started!

00:00:19: %LINK−3−UPDOWN: Interface BRI0/0, changed state to up00:00:19: %LINK−3−UPDOWN: Interface Ethernet0/0, changed state to up

00:00:19: %LINK−3−UPDOWN: Interface Ethernet0/1, changed state to up

00:00:19: %LINK−3−UPDOWN: Interface Serial0/0, changed state to down

00:00:19: %LINK−3−UPDOWN: Interface Serial0/1, changed state to down

00:00:20: %LINEPROTO−5−UPDOWN: Line protocol on Interface BRI0/0,

changed state to down

00:00:20: %LINEPROTO−5−UPDOWN: Line protocol on Interface Ethernet0/0,

changed state to up

Router>

00:00:20: %LINEPROTO−5−UPDOWN: Line protocol on Interface Ethernet0/1,

changed state to up

00:00:20: %LINEPROTO−5−UPDOWN: Line protocol on Interface Serial0/0,

changed state to down

00:00:20: %LINEPROTO−5−UPDOWN: Line protocol on Interface Serial0/1,

changed state to down

00:00:50: %SYS−5−RESTART: System restarted −−

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600−IS−M), Version 12.0(7)T, RELEASE SOFTWARE (fc2)

Copyright (c) 1986−1999 by cisco Systems, Inc.

Compiled Tue 07−Dec−99 02:21 by phanguye

00:00:50: %LINK−5−CHANGED: Interface BRI0/0,

changed state to administratively down

00:00:52: %LINK−5−CHANGED: Interface Ethernet0/0,

changed state to administratively down

00:00:52: %LINK−5−CHANGED: Interface Serial0/0,

changed state to administratively down

00:00:52: %LINK−5−CHANGED: Interface Ethernet0/1,

changed state to administratively down

00:00:52: %LINK−5−CHANGED: Interface Serial0/1,

changed state to administratively down

00:00:53: %LINEPROTO−5−UPDOWN: Line protocol on Interface Ethernet0/0,

changed state to down

00:00:53: %LINEPROTO−5−UPDOWN: Line protocol on Interface Ethernet0/1,

changed state to down

Router>

Router>enable

Router#copy startup−config running−config

Destination filename [running−config]?

1324 bytes copied in 2.35 secs (662 bytes/sec)

Router#

00:01:24: %LINEPROTO−5−UPDOWN: Line protocol on Interface BRI0/0:1,

changed state to down

00:01:24: %LINEPROTO−5−UPDOWN: Line protocol on Interface BRI0/0:2,

changed state to down

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#enable secret < password >

Router(config)#^Z

00:01:54: %SYS−5−CONFIG_I: Configured from console by console

Router#show ip interface brief

Interface IP−Address OK? Method Status Protocol

Ethernet0/0 10.200.40.37 YES TFTP administratively down down

Serial0/0 unassigned YES TFTP administratively down down

BRI0/0 193.251.121.157 YES unset administratively down down

BRI0/0:1 unassigned YES unset administratively down down

BRI0/0:2 unassigned YES unset administratively down down

Ethernet0/1 unassigned YES TFTP administratively down down

Serial0/1 unassigned YES TFTP administratively down down

Loopback0 193.251.121.157 YES TFTP up up

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface Ethernet0/0

Router(config−if)#no shutdown

Router(config−if)#

00:02:14: %LINK−3−UPDOWN: Interface Ethernet0/0, changed state to up00:02:15: %LINEPROTO−5−UPDOWN: Line protocol on Interface Ethernet0/0,

changed state to up

Router(config−if)#interface BRI0/0

Router(config−if)#no shutdown

Router(config−if)#

00:02:26: %LINK−3−UPDOWN: Interface BRI0/0:1, changed state to down

00:02:26: %LINK−3−UPDOWN: Interface BRI0/0:2, changed state to down

00:02:26: %LINK−3−UPDOWN: Interface BRI0/0, changed state to up

00:02:115964116991: %ISDN−6−LAYER2UP: Layer 2 for Interface BR0/0,

TEI 68 changed to up

Router(config−if)#^Z

Router#

00:02:35: %SYS−5−CONFIG_I: Configured from console by console

Router#copy running−config startup−config

Destination filename [startup−config]?

Building configuration...

[OK]

Router#show version

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600−IS−M), Version 12.0(7)T, RELEASE SOFTWARE (fc2)

Copyright (c) 1986−1999 by cisco Systems, Inc.

Compiled Tue 07−Dec−99 02:21 by phanguye

Image text−base: 0x80008088, data−base: 0x80C524F8

ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

Router uptime is 3 minutes

System returned to ROM by abort at PC 0x802D0B60

System image file is "flash:c2600−is−mz.120−7.T"

cisco 2611 (MPC860) processor (revision 0x202)

with 26624K/6144K bytes of memory.

Processor board ID JAB031202NK (3878188963)

M860 processor: part number 0, mask 49

Bridging software.

X.25 software, Version 3.0.0.

Basic Rate ISDN software, Version 1.1.

2 Ethernet/IEEE 802.3 interface(s)

2 Serial(sync/async) network interface(s)

1 ISDN Basic Rate interface(s)

32K bytes of non−volatile configuration memory.

8192K bytes of processor board System flash partition 1 (Read/Write)

8192K bytes of processor board System flash partition 2 (Read/Write)

Configuration register is 0x2142

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#config−register 0x2102

Router(config)#^Z

00:03:20: %SYS−5−CONFIG_I: Configured from console by console

Router#show version

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600−IS−M), Version 12.0(7)T, RELEASE SOFTWARE (fc2)

Copyright (c) 1986−1999 by cisco Systems, Inc.

Compiled Tue 07−Dec−99 02:21 by phanguye

Image text−base: 0x80008088, data−base: 0x80C524F8

ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

Router uptime is 3 minutes

System returned to ROM by abort at PC 0x802D0B60

System image file is "flash:c2600−is−mz.120−7.T"

cisco 2611 (MPC860) processor (revision 0x202) with 26624K/6144K bytes of memory.

Processor board ID JAB031202NK (3878188963)

M860 processor: part number 0, mask 49

Bridging software.

X.25 software, Version 3.0.0.

Basic Rate ISDN software, Version 1.1.

2 Ethernet/IEEE 802.3 interface(s)

2 Serial(sync/async) network interface(s)

1 ISDN Basic Rate interface(s)

32K bytes of non−volatile configuration memory.

8192K bytes of processor board System flash partition 1 (Read/Write)

8192K bytes of processor board System flash partition 2 (Read/Write)

Configuration register is 0x2142 (will be 0x2102 at next reload)

Router#